Typewriter mode changes scroll position to random location (may be a multiple monitor connect/disconnect issue)

Paul Solt's Avatar

Paul Solt

01 Sep, 2020 02:34 PM

When I enable or disable type writer mode it will randomly change my current scroll position.

1. I want my scroll position to animate to the center based on cursor position.
2. If I'm leaving typewriter mode, it should keep my scroll position (unless I'm at the end of the file ... if you don't support over scrolling)

I use Type writer mode to write, but I need to switch off the mode when I edit. Otherwise it drives me insane.

I have a 5k UltraFine at home, I use my laptop by itself on my lap, and then I have a 27" Thunderbolt at my work office. In traveling between these locations I run into issues with typewriter mode moving my scroll position to the wrong spot when I first enable it, or disable it. Then I either need to start typing something, or manually fix my scroll position.

https://www.loom.com/share/7324a012a0dc447b95754c290160e8de

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac