Select-All Bug

Ernesto Salcedo's Avatar

Ernesto Salcedo

07 Jun, 2020 12:09 AM

I have been having a recurrent problem with the select all functionality. My workflow involves selecting all of the markdown, copying as html, and pasting the html into my web browser tool. More often than not, however, once I select all of the markdown in Composer, I am unable to un-select the text in Composer. And worse, if I press escape, then I invoke the word completion feature (old mac cocoa app feature), and accidentally replace all of my markdown with whatever random word is selected by the mac. Undo fixes that problem, but still a big pain and scares me every time. So, my question is two-parts: 1) has anyone run into this select-all problem, where you are unable to un-select. And is there a fix? 2) Is there a way to change the keybinding for word completion in Composer for the escape key to anything else?

  1. Support Staff 1 Posted by Fletcher on 07 Jun, 2020 01:41 AM

    Fletcher's Avatar

    I have never heard of this happening, and can't imagine how it happens. It sounds like something outside of Composer interfering.

    When you say you can't unselect the text -- what exactly are you doing to unselect the text?

    Have you tried rebooting your Mac?

    Are you running any other software at the time?

    Have you tried this with a new user account on your Mac?

    Fletcher

  2. 2 Posted by ernesto.salcedo on 07 Jun, 2020 03:01 AM

    ernesto.salcedo's Avatar

    Thanks for your quick reply.

    Just an FYI, I try to keep all of my software and the operating system up to date and make sure to regularly invoke optimization software for my Mac. And restart my mac regularly.

    My first instinct when I’m stuck is to use the escape key, and that always invokes the Mac Word Completion function, which inadvertently replaces all of my markdown with a single word.

    I next start clicking around, both on the markdown panel, and then the preview panel. Clicking on the preview panel usually works, but not always. For some reason, clicking on the markdown panel brings up the contextual menu, as if I were right-clicking, which I definitely was not doing.

    However, based on your comments, I went into ~/Library/Preferences folder, found a file called "com.multimarkdown.composer4.mac.plist”, moved that file to the desktop, and restarted Composer. That seems to fix some, but not all my problems. I still get the Escape-key-invokes-word-completion. I’ll mess around with generator a new user next.

    Thank you,

    Ernie

  3. Support Staff 3 Posted by Fletcher on 18 Jun, 2020 12:27 PM

    Fletcher's Avatar

    Ernie,

    The right-click thing sounds almost like a stuck key on the keyboard or maybe a faulty mouse/trackpad??? I'm not sure that Composer itself can cause that to happen.

    F-

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac