significant typing lag

Andrew Hayes's Avatar

Andrew Hayes

18 Oct, 2018 11:31 AM

Significant typing lag occurs while editing a file (ca. 9000 words, 60K). The file resides in icloud drive, and has been accessed using the Open in . . . document picker. Live preview is turned off. Typewriter mode is on. I've attached a video clip to illustrate. System details: iOS 12.0.1, ipad pro 10.5 in.

  1. Support Staff 1 Posted by Fletcher on 23 Oct, 2018 01:14 AM

    Fletcher's Avatar

    Do you have the "Always perform full reload when updating preview"
    setting enabled? Disable that to improve performance. (iDevices
    apparently don't have the same ability to refresh web views as quickly.)

    Fletcher

  2. 2 Posted by Hayes, Andrew on 24 Oct, 2018 01:42 PM

    Hayes, Andrew's Avatar

    Thanks for the reply. I have kept that setting turned off from the first moment I installed the Composer beta.

    My current settings are: "Update preview only when file is saved" with "Always perform full reload . . ." unchecked. Scrolling synchronization is turned on, but I tried turning that off too, and doing that makes no difference to the typing lag. (I generally don't work with the preview showing, in any case.)

    AJH
    On Oct 23, 2018, 12:00 PM -0400, Fletcher <[email blocked]>, wrote:

  3. Support Staff 3 Posted by Fletcher on 24 Oct, 2018 04:25 PM

    Fletcher's Avatar

    Can you send me the file and tell me where you were editing when it was slow?

    Is it slow if you edit the end of the file?

    Is it slow on the macOS version of composer?

    Fletcher

    Sent from my iPhone

  4. 4 Posted by Hayes, Andrew on 01 Nov, 2018 03:25 PM

    Hayes, Andrew's Avatar

    Sorry for the delayed response. Yes. It turns out that if I edit the end of the file, typing seems to work as usual (no significant lag). If I scroll up to a passage roughly in the middle of the document, the typing lag problem occurs. Editing a few paragraphs from the end shows some lag, but not as much if I edit the middle of the document.

    I haven't tried editing the file on macOS (I don't use my mac as much anymore.) When I get home I can give it a try. The file is attached. It's the main part of an academic article.

    AJH
    On Oct 24, 2018, 12:25 PM -0400, Fletcher <[email blocked]>, wrote:

  5. Support Staff 5 Posted by Fletcher on 01 Nov, 2018 08:01 PM

    Fletcher's Avatar

    I'll run some profiling tests to try and figure out what's going on.

    It works fine in macOS, but not in iOS.

    Short version -- there are two main things that affect performance:

    1. How much (or little) of the document has to be re-parsed for
    MultiMarkdown when you type. For example, typing in a long list can
    require that the entire list be processed, because you can alter the
    meaning of "distant" lines by adding a "*" somewhere. This is under the
    control of Composer and is the same across macOS/iOS. Some documents
    are simply more complicated than others though.

    2. How quickly updated styling information in a textview is applied.
    This is more under the control of the OS, though I have some control
    over it. For example, changing the height of a line at the top changes
    the position of every subsequent line. macOS and iOS may handle this
    quite differently, and I have some limited control over it. I'll try to
    dig in to see whether I can improve settings to make performance in long
    documents better. It should be possible.

    In this case, it *seems* that performance degrades the further "up" in
    the document I am when typing. Which is more consistent with the 2nd
    issue above.

    Thanks for the document, and I'll let you know what I find!

    Fletcher

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • CEF813E5-CF11-4269-9EA7-1C53979A7658.MOV 500 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac