saving impossible

adrian's Avatar


06 Feb, 2022 10:40 AM

Dear Fletcher,
Bevore going so far as to write you about not being able only very recently (no updates in the meantime) to save any changes to any file originally created in MMC, I have tried all solutions which crossed my mind (which I list up lower down).

First of all, the description of the problem:
(Here I refer to MMC running under macOS 11.6.1) When I try saving an already open file, I get first the pop-up error window
Screenshot 2022-02-06 at 10.13.56.png
and if I choose «save anyway», I get
Screenshot 2022-02-06 at 10.14.10.png

As you'd expect, I checked repeatedly, that the permissions are fine (that is, as they have always been) and I even went so far as to reset them all to
Read + Write + Execute for myself, for Group, and for Everybody
not only for the file in question, but, going up the tree, of all folders up to, and including Documents.

I also offered full accessability and full disk control to MMC (see Screenshot 2022-02-06 at 10.25.18.png and Screenshot 2022-02-06 at 10.28.02.png , respectively).

I have my disk partitioned to run both macOS 11.5.1 and macOS 11.6.1
So I copied all files I used to work on from the partition macOS 11.6.1 to the other partition, that is, macOX 11.5.1
and installed afresh MMC from AppStore in this partition. I also did not forget to check again the permissions for files and folders (as above) and also to give MMC the same rights in System Preferences as above.

All this to no avail, I am sorry to say.

Could you please help?
Thank you,

  1. Support Staff 1 Posted by Fletcher on 06 Feb, 2022 01:03 PM

    Fletcher's Avatar


    Thanks for taking the time to describe your efforts to troubleshoot.

    That error message is from macOS, not Composer. Unfortunately, the problem is almost assuredly with your computer, not with Composer. Which means there is little I can do to help beyond general troubleshooting advice.

    1. Both screenshots include the same filename. Does it happen with other files as well?

    2. What about creating a new file in Composer -- can you save that?

    3. The folder name appears to have unicode characters in it. What about a "normal" ASCII folder name? And just a different folder in general?

    4. Have you tried Disk Utility -> First Aid or repair permissions?

    When you copied to the other partition, I assume you mean that you rebooted to run a different version of the OS. If not, definitely reboot.

    Finally, and least satisfying, have you been updating your OS "in place" for quite a while, or do you periodically start fresh by wiping the driving and installing new? Over the years I have noticed unusual problems occurring if I upgrade in place too often, and have seen this in other users as well. My usual practice now is to start with a clean hard drive if I am going to upgrade to a new major OS version (e.g. 10.14 to 10.15, or 11 to 12). Though if this is happening on two different partitions (presumably with different upgrade paths), this is a bit less likely of an explanation for this particular case.

    Let me know what you find and I'll try to think of some other ideas as well.


  2. 2 Posted by adrian on 06 Feb, 2022 02:03 PM

    adrian's Avatar

    Thank you so much, Fletcher, for your swift reaction. I should have added, that I did not experience any similar problem with any other application in either partition. On the other hand, in MMC I cannot save one single, already existing (older) file after editing it.
    So, I think, I have answered now to your point1.

    Now, over to your other suggestions:

    To 2: I have just created a new file, and I had absolutely no problem in saving it in both volumes (see Screenshot 2022-02-06 at 13.37.16.png and Screenshot 2022-02-06 at 13.38.12.png). Moreover, after saving it, I have changed it, and saved it again (in both partitions, that is macOS11.5.1, as well as in macOS 11.6.1). Also overwriting goes quite nicely, without any problem in both partitions.

    To 4: I forgot to say, that I have indeed run Disk Utility → First Aid in the macOS11.6.1 partition before opening this new forum thread. Just a minute ago, I have run the same unility also in the partition where I am now (that is, macOS11.5.1) as you can see in Screenshot 2022-02-06 at 13.43.30.png and 2022-02-06 FirstAid on macOS-11-5-1.txt.

    About your last point: it is true, that I have updated really many major OSes on top, or rather instead, of each other (as you call it, «in place») .

    I continue to be mystified that my problem is exclusively with all older md files created in MMC, and with no other new .md file and with no other application.

    What do you think might be the cause?

    Thank you so much,

  3. 3 Posted by adrian on 06 Feb, 2022 02:04 PM

    adrian's Avatar

    sorry, I forgot the attachement.

    I should also have said, that before opening this thread, I have deleted all driver caches, all icon caches, all font caches, all unprotected caches of all applications, and all protected caches of the respective OS. It goes without saying that I have tried also SMC resets and NVRAM resets. I do not know how to increase even further pristine state of each partition.

    Many thanks,

  4. Support Staff 4 Posted by Fletcher on 06 Feb, 2022 03:05 PM

    Fletcher's Avatar

    So the point of failure is the single file, not Composer itself.

    1. If you want to quickly resolve the issue, copy the contents of the file and save as a new file. Delete the problematic file, and then copy the duplicate back to the original location.

    2. If you want to spend a bit more time experimenting, try opening the file and saving it in TextEdit instead of Composer. It's just a text file, so any text editor can read and save it. It would be interesting to know if there is an error in this instance. But whether an error occurs or not, it won't shed much light on the cause of the problem.

    My guess is a disk error/corruption on the file in question, but that's a guess.

    As to the upgrading, part of the problem, I believe but do not know with 100% certainty, is that the new OS is not "instead of" as you put it. It is more "on top" of the existing os. So a corrupted file in the older OS, that does not change in the update is not "fixed" when updating. It remains corrupted. By doing a wipe and fresh install, any disk errors on the old drive are no longer a factor. It's also an opportunity to clean out stuff you no longer use. But it does take more time and requires more care to avoid losing something important...


  5. 5 Posted by adrian on 07 Feb, 2022 05:12 AM

    adrian's Avatar

    Dear Fletcher,
    thank you so much for your help.
    I have opened (not in TextEdit, but in MMC) all older .md files, and I saved them in a empty folder (with the same name as the old one to which I prefixed an exclamation mark) with an identical sub-folders structure. All is swell now.

    The much more serious problem to which you drew my attention remains, of course, and I think seriously of buying an external HD with thuderbolt3 connection, exactly to be able to follow your advice.
    Thank you so much also for this, under-the-bonnet, advice,

  6. Support Staff 6 Posted by Fletcher on 08 Feb, 2022 01:25 PM

    Fletcher's Avatar

    The pattern I have gotten into over the years includes:

    1. I "leapfrog" my two machines (desktop and laptop). I upgrade the OS one one of them, and leave the other one unchanged. This lets me test my programs on two different major OS versions. If another app breaks (one that I purchased), I can still use it on the other machine while I figure out a solution.

    2. When it's time to upgrade a machine, I jump ahead to the latest version and usually will wipe the drive and start fresh. This means it takes longer to get everything working, but it's more reliable. It also forces me to be more organized, and I've streamlined the software that I need to install, and have systems to make it really easy to gain access to my important documents/folders.

    It's sort of like a car -- you can just drive it every day and not maintain it, but eventually it's going to break down and leave you stranded. Maintenance is annoying, but helps avoid major problems. ;)

    Good luck!


  7. Fletcher closed this discussion on 08 Feb, 2022 01:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac