Tables not formatting

Vince's Avatar


08 Sep, 2017 07:30 PM

B39 on OSX 10.12.6.

I tried another first (for me) today: a table in MD (any flavor). It didn't work. So I went to the MMD sample document that you gave me a link to earlier and pasted the entire Table section into a brand new document. It didn't work, either. Am I missing something, or this a bug?

I'm attaching a screen print. Hopefully.

  1. Support Staff 1 Posted by Fletcher on 08 Sep, 2017 07:41 PM

    Fletcher's Avatar

    V6 tables require caption after table, not before.

    Sent from my iPhone

  2. 2 Posted by Vince on 08 Sep, 2017 07:49 PM

    Vince's Avatar

    Well, OK, that makes the sample in a blank document work, thanks!

    But it still doesn't work in a regular document. I copied the first few lines of the table to my test document (the same three lines in the blank-except-for-the-tables document work fine, i.e. Preview shows a table.), and still don't get a table. See attached new screenprint (hopefully).

  3. 3 Posted by Vince on 08 Sep, 2017 07:52 PM

    Vince's Avatar

    Here's what those same three lines look like in the blank-except-for-the-tables document. (Everything is the same for both, i.e. same preview (GitHub), etc.)

  4. Support Staff 4 Posted by Fletcher on 08 Sep, 2017 07:56 PM

    Fletcher's Avatar

    Both of those screenshots show tables.

    Was there something else where it didn't work?

  5. 5 Posted by Vince Rice on 08 Sep, 2017 07:59 PM

    Vince Rice's Avatar

    ?? Not sure what you're calling a "table," but the preview in those screenshots don't look anything alike. The second screenshot shows a properly formatted table. The first screen (of the last two) shows a bunch of text, not a table.

  6. Support Staff 6 Posted by Fletcher on 08 Sep, 2017 08:01 PM

    Fletcher's Avatar

    Both of them show text lined in columns, with bold applied to first row.

    I can’t control what CSS you apply.

    They’re both tables. Check the HTML source if you don’t believe me.

  7. 7 Posted by Vince on 09 Sep, 2017 10:32 PM

    Vince's Avatar

    Pay attention — I already said the previews were the same.

    But of course they weren't. Which means I need to pay attention. What's bad is that I thought I checked that (hence my "they're the same" statement) — the default was the same as the new one which was the same as the old one. Except the old one wasn't the default. (Remember that changing the default should change the open windows discussion?)

    Sigh. Move along, nothing to see here, nothing to see, move along. (Sorry for the noise.)

  8. Support Staff 8 Posted by Fletcher on 09 Sep, 2017 11:37 PM

    Fletcher's Avatar

    No worries. ;)

    Sent from my iPhone

  9. Fletcher closed this discussion on 10 Sep, 2017 12:07 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac