Problem with integrated with Marked

Nathan's Avatar

Nathan

29 Mar, 2018 03:34 AM

I have been using MM Composer for a while now and I just recently started using Marked 2. Everything was fine until a few days ago, now Marked won't preview files correctly. I created a file that had quite a few boxes but they did not show up in the preview. I have let Brett Tepestra know but I wanted to let you know, too. I don't know what is causing this problem.

  1. Support Staff 1 Posted by Fletcher on 29 Mar, 2018 12:21 PM

    Fletcher's Avatar

    Nathan,

    Sorry you're having trouble.

    The only thing Composer controls is sending the file name to Marked. Marked reads the file itself and handles the preview. So that portion is under Brett's control.

    Does it preview correctly in Composer?

    Fletcher

    Sent from my iPhone

  2. 2 Posted by nathan king on 31 Mar, 2018 10:25 PM

    nathan king's Avatar

    Composer was working fine and then I updated it. I checked and Compsoer is not previewing the file right either. I created a table and the Markdown showed up on the preview too.
    --------------------------------------------
    On Thu, 3/29/18, Fletcher <[email blocked]> wrote:

     Subject: Re: Problem with integrated with Marked [Questions #5189]
     To: [email blocked]
     Date: Thursday, March 29, 2018, 7:21 AM

     #yiv1316113661 pre {
     width:92%;margin:10px 2%;padding:5px
     2%;background:#efefef;border:1px solid #d6d6d6;}
     #yiv1316113661 blockquote {
     margin-left:0;padding-left:1em;border-left:5px solid #ccc;}

               // Please reply above this
     line

  3. Support Staff 3 Posted by Fletcher on 31 Mar, 2018 10:41 PM

    Fletcher's Avatar

    If you send me the file I will take a look.

    Sent from my iPhone

  4. 4 Posted by Nathan King on 03 Apr, 2018 01:46 AM

    Nathan King's Avatar

    Here is the file, but now it is working fine in Composer preview. It still doesn't work in Marked but I am trying to work that out with that developer.

  5. Support Staff 5 Posted by Fletcher on 03 Apr, 2018 02:08 AM

    Fletcher's Avatar

    Nathan,

    You have invalid HTML -- the <strong> is not closed.

    And the MMD table is invalid:

    * The partially empty line before "Outline" does not specify the correct
    number of table cells. You can delete that line without changing
    meaning of output.

    * The last table specifies an extra table cell -- delete the last "|".

    Fixing those will give you a valid HTML document, which may or may not
    fix the issues with Marked. (Brett uses MMD to convert to HTML, but I
    *believe* he still uses version 5, not version 6? He also does his own
    post-processing, and that may choke on invalid HTML??)

    Fletcher

  6. 6 Posted by nathan king on 04 Apr, 2018 03:45 AM

    nathan king's Avatar

    Thank you. That fixed the problem on both ends.

          From: Fletcher <[email blocked]>
     To: [email blocked]
     Sent: Monday, April 2, 2018 9:08 PM
     Subject: Re: Problem with integrated with Marked [Questions #5189]

     #yiv7346775994 pre {width:92%;margin:10px 2%;padding:5px 2%;background:#efefef;border:1px solid #d6d6d6;}#yiv7346775994 blockquote {margin-left:0;padding-left:1em;border-left:5px solid #ccc;}

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac