Loading MathJax from a local location on HDD?

christian.kolen's Avatar

christian.kolen

10 Nov, 2015 05:27 AM

I tried to put MathJax local in hope of making it faster to render in MMD Composer. But after I test it as

```
HTML Header: <script type="text/javascript"
src="file:///Users/***/mathjax/latest/MathJax.js?config=TeX-AMS_CHTML">
</script>
```

The preview in MMD Composer doesn't work. However if I use MMD2HTML and open it in Safari, the code works fine.

By the way, I installed the one downloaded from the website, so it shouldn't have privilege problem to read other folder?

In short, how should I load a local MathJax from HDD in MMD Composer?
Thanks.

  1. Support Staff 1 Posted by Fletcher on 10 Nov, 2015 01:30 PM

    Fletcher's Avatar

    The sample source you embedded seems to have non-matching quotation
    marks. That may or may not be your problem.

    After changing the HTML header, be sure to force a full refresh of the
    Preview pane so that the changes are incorporated. Or close and reopen
    the document.

    Composer's preview (from the Non-sandboxed version, as you mention) has
    no problem with local scripts that I have found -- the problem is in all
    likelihood in your HTML link or configuration.

    Even the app-store version of Composer can access local files, if you
    give it permission when it asks.

    All of that said, remember that MathJax does it's magic when an HTML
    document is FIRST loaded. If you modify a document (and therefore the
    HTML preview), the formatting goes away. Again, the way to fix this is
    to manually refresh the preview when you wish to see the formatted math.
      (In v3 anyways, v2 would do a full refresh with each change, which was
    horribly inefficient).

    Fletcher

  2. 2 Posted by christian.kolen on 11 Nov, 2015 04:27 AM

    christian.kolen's Avatar

    Thanks.

    I tried it again after knowing from you it is a correct way to do.

    I was on a different computer though. I use exactly the same code and it works again. No idea why it wasn't working on the other computer. But I knew something is wrong when the HTML output works but the preview isn't.

    Since you mention the beta, I just tried it and it's great! But I don't know why the MathJax preview doesn't work in the Pro version, but the "standard" version. Both beta are newly downloaded 3.0b36 from <http://support.multimarkdown.com/kb/future-plans/where-can-i-download-the-beta-for-v3>

  3. 3 Posted by christian.kolen on 11 Nov, 2015 06:01 AM

    christian.kolen's Avatar

    In case I wasn't clear. It works in the standard version but not the Pro version.

  4. Support Staff 4 Posted by Fletcher on 11 Nov, 2015 02:10 PM

    Fletcher's Avatar

    Works fine for me in Pro version.

    F-

  5. Support Staff 5 Posted by Fletcher on 11 Nov, 2015 02:11 PM

    Fletcher's Avatar

    BTW -- you probably didn't change the preferences in one, so that version was using the internet location of MathJax. You probably don't have an accurate local file:/// URL, so Composer can't find your local MathJax when you disable the internet MathJax.

    But again, it works fine for me when properly configured.

    F-

  6. Fletcher closed this discussion on 10 Dec, 2015 11:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac