beta 3.0 won't open

Timotheus's Avatar

Timotheus

16 Apr, 2017 09:43 PM

I have a perfectly working copy of version 2.9, both on desktop and laptop. Yesterday I downloaded version 3.0 (b49), but it stubbornly refuses to open, on both computers. What am I doing wrong?

  1. Support Staff 1 Posted by Fletcher on 16 Apr, 2017 11:38 PM

    Fletcher's Avatar

    You'll need to be more specific, but the previous beta expired and a new
    version (3.0b50) was released today.

    Try running it again and it should update for you.

    F-

  2. 2 Posted by fhaist on 05 May, 2017 05:15 PM

    fhaist's Avatar

    I have a similar problem with beta 3 not opening. This one I believe is my fault, but I don't know how to fix. I installed MM 2.9 on my machine and then downloaded the MM 3 beta (3.0b49) as both Composer and Composer Pro. I inadvertently tried to open the beta before I had run the 2.9 version first. Each time I try to open the beta nothing happens -- no warning or other issue. I've opened and run the 2.9 version, but still no luck with the beta. I looked through the library and didn't see anything obvious I could delete. Any recommendations greatly appreciated. Thanks.

    ---Frank

  3. 3 Posted by fhaist on 05 May, 2017 05:20 PM

    fhaist's Avatar

    Sorry, I should have mentioned that no upgrade message appears when I start the beta and the download links are only to the b49. Is there another way I can get b50 or the latest build if there's something newer?

    ---Frank

  4. Support Staff 4 Posted by Fletcher on 05 May, 2017 05:32 PM

    Fletcher's Avatar

    I don't always update the download URLs with each update, but it's not like the URL is some big mystery to figure out... ;)

    But even if you download a slightly older version, it will still prompt you to update, as long as you are online. (I just checked it to make sure, and no worries).

    I've never heard of nothing happening when you open the beta -- it should give you an expired message and offer to update, or it should work as usual. Are you sure the beta is not already running when you double click the icon?

    Fletcher

  5. 5 Posted by fhaist on 05 May, 2017 05:44 PM

    fhaist's Avatar

    I got it to work. And yes, the head slap with the URL being fairly obvious. The problem was that the App store didn't register a valid receipt when I installed 2.9. Found that out by running the app within the package and that was the terminal message. Same problem the second time I reinstalled. It took reinstalling the third time, quitting the App Store app, reopening that and running "Open" from within the App Store. Now the beta is working. Thanks for your quick response.

    ---Frank

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac