MultiMarkDown Converter

Victor Warner's Avatar

Victor Warner

26 Mar, 2017 10:36 AM

I cannot get this application to convert files at all.

Although the application shows a file as converted, there is no (converted) file anywhere on my system.

I have used versions 1.0 and 1.0.1. I have tried with the latter version, using the reset menu option. I have uninstalled and then installed again from the App Store. Also tried rebooting. macOS = 10.12.3.

The above is consistent behaviour on two different types of Macs, both running the same macOS.

  1. Support Staff 1 Posted by Fletcher on 26 Mar, 2017 12:32 PM

    Fletcher's Avatar

    Victor,

    I'm sorry you're having so much trouble. That is bizarre -- the only trouble I have had was the intermittent sandboxing bookmark issue, which in my testing seems fixed with 1.0.1 (after using the reset option.)

    After you used the reset option, did Converter ask you again for permission to access the folder?

    Can you send me one of your files so I can test it on my machine?

    Can you send me a copy of the logging output in the bottom of the window? I'm wondering if there is something strange about your directory path that is confusing it (e.g. strange characters, etc.)??

    You might want to email me directly instead of this web support OR make the conversation private if you have personal information in the document.

    Thanks,

    FTP

  2. 2 Posted by Victor Warner on 26 Mar, 2017 04:45 PM

    Victor Warner's Avatar

    Thank you for the response.

    There is nothing confidential/private about the documents I tried with the app.

    They were created with nvAlt, further edited in MMC version 3.0, and some edited also with TableFlip. A file is attached as well as a screen shot of the result of using the file with MultiMarkDown Convertor.

  3. Support Staff 3 Posted by Fletcher on 26 Mar, 2017 05:05 PM

    Fletcher's Avatar

    The files work fine for me. This is really strange -- I appreciate you helping me try and fix this.

    1. Can you paste the filename you used into a message here? The file attachments had the filenames changed, so maybe there is an unusual character in there somewhere. But regular spaces, commas, and hyphens (even an en-dash) work fine for me.

    2. Try changing the filenames to something simple, like "file.md" without spaces or punctuation

    3. After using the "Reset Settings" command, did Converter ask you again for permissions to access a folder? If not, there's something strange happening.

    Thanks!!

    Fletcher

  4. 4 Posted by Victor Warner on 26 Mar, 2017 08:07 PM

    Victor Warner's Avatar

    Specific responses:

    Can you paste the filename you used into a message here? The file attachments had the filenames changed, so maybe there is an unusual character in there somewhere. But regular spaces, commas, and hyphens (even an en-dash) work fine for me.

    Polish - this, that.md.
    Polish - months.md

    (I copied these from Finder)

    Try changing the filenames to something simple, like "file.md" without spaces or punctuation

    I renamed the files to file.md and tried again, but with the same result.

    After using the "Reset Settings" command, did Converter ask you again for permissions to access a folder? If not, there's something strange happening.

    No. Just a small window stating: "Reset settings back to defaults."

    I also recorded a screen movie which shows what happens when I carried out "Reset Settings".

  5. Support Staff 5 Posted by Fletcher on 26 Mar, 2017 08:41 PM

    Fletcher's Avatar

    The filenames still work just fine for me.

    It won't ask for permissions until you drop a folder after resetting permissions.

    The video is helpful. Will you try another with the following:

    1. Drag/drop file from finder to Converter -- please leave finder window and converter both visible, or use a file on your desktop. This will let me make sure I'm not missing anything subtle, and see that the file does not appear.

    2. Reset settings again (on video)

    3. Drag/drop same file again. It should ask for permission -- give it permission and see what happens.

    Also -- any "unusual" software running on your machine? What happens if you reboot? Does the problem go away?

    If that doesn't do it, I'll build a debugging version for you with the following:

    1. A non-sandboxed build so you can at least use the app

    2. More extensive debugging commands to try and track down the problem.

    Thanks again!!

    Fletcher

  6. 6 Posted by Victor Warner on 26 Mar, 2017 10:54 PM

    Victor Warner's Avatar

    I tried again. I rebooted the machine. Ran CleanMyMac.

    1. Reset.
    2. Tried again with the same file from the same folder /home/victor/vwdata/data/notes
    3. Result: no file converted.
    4. Then copied file to Desktop. Tried to convert: the file was converted.
    5. Then copied file to folder within Documents. Tried to converted: the file was converted.
    6. Then tried one more time to convert file from /home/victor/vwdata/data/notes. This time the file was converted.

    Tried several more files, all converting now.

    At no step was I asked for permission.

    I am not sure what constitutes 'Unusual' software. e.g. vmWare? DevonThink? Bartender. Default Folder X, Moom? Keyboard Maestro? to name a few.

    I shall try tomorrow on the second machine where MultiMarkDown Converter was not working.

    The video for steps for 4 and 6 is attached. Apologies for the poor quality, but I wished to keep it within the 10MB limit.

  7. Support Staff 7 Posted by Fletcher on 27 Mar, 2017 01:08 AM

    Fletcher's Avatar
    1. Glad it's working.

    2. I have no idea what changed.

    "Back in the day" application preferences were written to files immediately, and deleting the files resulted in immediately wiping the settings. Several OS X versions ago (10.11?? 10.10??) this changed. If you delete preference files, you have to reboot the machine for the change to really take effect.

    In this instance, I delete the preferences within the app, which has always taken effect immediately for me. Perhaps there was something strange going on that resulted residual settings??? Hard for me to believe, but perhaps possible.

    The asking for permission was the window that pops up asking you to hit the open button -- it looks just like a regular file open dialog. It shows up on the video once or twice.

    I wonder if Default Folder X could be having an effect? If it ever happens again, be sure to take a look at the file directory and make sure that the folder you are being asked to approve matches the parent folder of the file you dragged. If it somehow requested permission for a different folder, this could result in the sandboxing permissions existing for the wrong folder.

    The more I think about it, the more that actually sounds like a reasonable theory.

    If your tests on the other computer confirm/refute that theory, I would love to hear about it.

    Thanks, and please let me know what happens next!!

    Fletcher

  8. 8 Posted by Victor Warner on 28 Mar, 2017 05:46 AM

    Victor Warner's Avatar

    I tried on the second Mac machine. Except for one successful instance (with a file placed in Desktop) MMMC would not convert files.

    After rebooting, running the maintenance utilities of CleanMyMac, uninstalling and reinstalling MMMC, MMMC now appears to convert all files regardless of the folder.

    However, there is one file which will not convert, regardless of which folder it is placed, and whatever its file name, and whether it is edited and then saved and then put through MMMC.

    The file is attached.

    [All of the above was done with DefaultFolder running and after quitting DefaultFolder = no difference.]

  9. Support Staff 9 Posted by Fletcher on 28 Mar, 2017 11:43 AM

    Fletcher's Avatar

    IF Default Folder was the problem, disabling it after the problem began would not fix it. My theory (and it's just a theory), is that it could interfere with the dialog used to gain read/write permission to the necessary folder. Once that happens, Converter is unaware that something is wrong and can't fix it.

    I'll have to wait and see if other users report the same thing. It's for reasons like this that I tend to avoid utilities like Default Folder X -- they tend to have very difficult to track down side effects that show up in unusual places. I've had to help track down similar issues with other utilities in the past.

    But again -- at this point I have no proof that Default folder X is the culprit here.

    That said, the deed wording document is a different issue. I can confirm trouble with this file on my machine. Interestingly, MMD v6 itself handles it just fine. The problem only happens in Converter. Specifically, it's related to these two lines:

    Le présent document a été signé en tant qu'acte et est délivré et prend effet à la date indiquée au début.
    
    Le présent document a été signé en tant qu'acte et est délivré et prend effet à la date indiquée ci-dissus.
    

    I'm trying to track down the problem. So far, it does not seem to be a file encoding issue (it's properly in UTF-8) and changing the options doesn't seem to be the problem.

    Again -- thank you for your persistence, and particularly for finding and sending this last file! I'll post an update when I figure it out.

    Fletcher

  10. Support Staff 10 Posted by Fletcher on 28 Mar, 2017 12:06 PM

    Fletcher's Avatar

    Made some headway. Specifically, the problem is in the character à.

    What I'm not sure of is why this character causes different issues in regular MMD vs the converter MMD, but I think it has to do with the way string encoding is handled.

    I'm working on a fix that will be included in MMD 6.0.1, and the next release of MMD Converter.

    Thanks again!!

    F-

  11. Support Staff 11 Posted by Fletcher on 28 Mar, 2017 12:36 PM

    Fletcher's Avatar

    Figured it out (this is a bit technical, but is here for posterity).

    Extended ASCII includes the character 160 (decimal) which is a non-breaking space. (http://www.ascii-code.com/).

    160 decimal is the same as 240 octal, or A0 in hex.

    à in UTF-8 is a two-byte character, which is C3A0.

    SOOOO..... When the MMD parser scans for whitespace, it identifies the A0 portion of the accented a as a non-breaking whitespace, which splits that character in half. This results in invalid UTF-8 strings, which apparently causes an undefined effect, leading to slightly different behaviors depending on how one gets there. MMD from the command-line works, but gives a corrupted character where the à used to be. MMD Converter gets an invalid string and refuses to do anything with it.

    Changing the parser to recognize C3A0 as a single character causes it not to split in half as whitespace. This fix works in both MMD and MMD Converter.

    I'll consider this part solved (with fix coming in next release to App Store), but still would love any confirmation from anyone else related to the possible Default Folder X issue.

    Thanks for a great bug find!!!

    Fletcher

  12. Support Staff 12 Posted by Fletcher on 28 Mar, 2017 01:16 PM

    Fletcher's Avatar

    1.0.2 has been submitted to the App Store that should fix the à issue for you.

    F-

  13. Support Staff 13 Posted by Fletcher on 30 Mar, 2017 12:32 AM

    Fletcher's Avatar

    UPDATE: The à issues remains fixed, but found similar issue with a different variant of non-breaking space.

    I dug into some more documentation, and recompiled MMD in a way that should improve support for non-ASCII characters and prevent these collisions. MMD 6.0.3 includes this improvement. I want to get a couple more test files to confirm, and will submit Converter 1.0.3 to include this as well.

    Thanks again to everyone who has helped me track down this issue!!

    Fletcher

  14. Fletcher closed this discussion on 31 Aug, 2017 01:16 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac