MultiMarkdown Composer Pro 3.0b49 having problems with HTML tags

Rob's Avatar

Rob

09 Mar, 2017 04:16 AM

Try pasting the following into a new file:

<div markdown=1>
<section class="appendices">

#Appendix #
##Report 1 ##

# Appendix #
## Report 2 ##

# Appendix #
## Report 3 ##

</div>
</section>

When I do that , the TOC shows this:

Appendix
    Report 1
    Report 2
    Report 3
Appendix
Appendix

Also, if you start an ordered list after one of the heading 2 items, it will not automatically number a new line when you hit return. If you remove the <div> and <section> tags, everything works fine.

Thanks,
Rob

  1. Support Staff 1 Posted by Fletcher on 09 Mar, 2017 12:06 PM

    Fletcher's Avatar

    I'm away from my Mac at the moment. Does the same thing happen when you use proper HTML? Your div and section tags aren't properly nested.

    In either case, MultiMarkdown v6 is almost ready which handles HTML differently. You can try your examples with Babelmark 2 to see how they work.

    Once MultiMarkdown 6 is finalized, I'll be moving Composer 3 to use it instead of MultiMarkdown 5.

    Fletcher

    Fletcher

    Sent from my iPhone

  2. 2 Posted by Rob Cope on 09 Mar, 2017 03:33 PM

    Rob Cope's Avatar

    Yes, it happens even with the tags properly nested. Sorry, that was a
    vestige of my test to see if nesting the `<div>` inside the `<section>`
    solved the problem (it didn't -- the markdown syntax was ignored
    altogether, which is what I would expect).

    In Bablemark 2, which uses MultiMarkdown 6 0.1.4a, I was unable to find
    any way to get it to parse the first H1 and H2 lines. I haven't tried
    building and testing 0.4.2b. The MultiMarkDown 5.1.0 is correct,
    assuming the `<div markdown=1>` tag is included.

    Thanks,
    Rob

  3. Support Staff 3 Posted by Fletcher on 10 Mar, 2017 01:05 AM

    Fletcher's Avatar

    Back on my computer (instead of phone).

    You left out the spaces after the Hash marks in the first two headers, which is what breaks them in MMD 6.

    As for the newline in a list issue -- you're actually inside HTML, not a list. So the "smart" editing features in Composer are disabled. This behavior will be slightly different in a future version of Composer that uses an entirely new engine based on MMD 6 and some other code.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac