QuickLook -- how to get it working with .mmd files?

Jonathan Clark's Avatar

Jonathan Clark

09 Oct, 2016 10:30 PM

I've tried 3 different QuickLook generators for MMD files, and with none of them can I get my multimarkdown content to render properly. I've tried the v1.3 one from this site most recently, and at least it shows the contents of the various .mmd files, but just as an un-styled text file. It shows .md files styled OK. Is there anything special I need to do to show .mmd files? If I change the .mmd extension to .md, then it styles it, but it doesn't show the front matter that I have.
I'm running OS X 10.11.6 not Sierra.

  1. Support Staff 1 Posted by Fletcher on 22 Oct, 2016 12:29 PM

    Fletcher's Avatar

    Another application is "highjacking" the UTI system. The mdls terminal command will help you figure out which application is being used instead.

    The "kMDItemContentType" should be "net.daringfireball.markdown" or "net.multimarkdown.text" if all is working properly.

    Also, be sure to reboot after changing QuickLook plugins.

  2. 2 Posted by Stephan Lamprec... on 23 Mar, 2017 05:28 PM

    Stephan Lamprecht's Avatar

    Hi there,

    same here. mdls showed another Contentype-Provider. But the big question is: How can i change this as a user to "net.multimarkdown.text" ??

    Regards
    Stephan

  3. Support Staff 3 Posted by Fletcher on 23 Mar, 2017 05:44 PM

    Fletcher's Avatar

    Unfortunately, Apple does not make this easy. In my experience, you have to delete the other application. You then have to reboot your Mac or reset the quicklook system in the terminal (Google it). Once it's working, you can try adding the other application back again.

    It's a frustrating system that works well when it works, but when it doesn't work it's difficult to fix.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac