problems after installing 3.0b39

francesco.caviglia's Avatar

francesco.caviglia

03 Dec, 2015 09:38 PM

Hi,
I just installed 3.0b39 and cannot open my last files.
The files are readable without problems in 2.8 (as well as in Byword and Haeropad).
I attach the shorter file and work with 2.8 for now.
Keep up the good work, MD-Composer is a real gem.
Francesco

  1. Support Staff 1 Posted by Fletcher on 03 Dec, 2015 09:43 PM

    Fletcher's Avatar

    Can you give more details?

    To the best of my knowledge, the only thing different between 3.0b38 and
    3.0b39 is the version number and expiration date. I didn't change the code.

    Fletcher

  2. 2 Posted by francesco.cavig... on 03 Dec, 2015 10:15 PM

    francesco.caviglia's Avatar

    Thanks for a very quick answer.
    If I try 
    to open the file from the finder, the icon of 3.0b39 in the dock makes a small jump and nothing happens.
    If I try to open the file from File/Open, I get a message “Cannot open the file”.

    I attach the file that gives the problem, but I don’t think the problem is in the md files.
    It seems that I cannot open any of my old .md files.

    I had to install the new version because the previous beta was expired.

    Thank you for your help
    Francesco

  3. Support Staff 3 Posted by Fletcher on 03 Dec, 2015 10:18 PM

    Fletcher's Avatar

    Try again and then look in the Console application to see if you're
    getting any error messages.

    F-

  4. 4 Posted by francesco.cavig... on 03 Dec, 2015 10:29 PM

    francesco.caviglia's Avatar

    03/12/15 23:25:36,268 MultiMarkdown Composer[19521]: UTI 'net.daringfireball.markdown' is not a valid file type for Composer
    (when opening from inside MD Composer)

    and then from the finder:
    03/12/15 23:27:48,281 CoreServicesUIAgent[19505]: Error -60005 creating authorization
    03/12/15 23:27:48,325 MultiMarkdown Composer[19521]: UTI 'net.daringfireball.markdown' is not a valid file type for Composer

    Hope it helps
    francesco

  5. 5 Posted by francesco.cavig... on 04 Dec, 2015 11:06 PM

    francesco.caviglia's Avatar

    I have tried to reinstall the program, with no success.
    I can save a file, but not open one.
    Any idea?

  6. Support Staff 6 Posted by Fletcher on 04 Dec, 2015 11:12 PM

    Fletcher's Avatar

    You have another application which is confusing the OS as to which UTI
    to use. Not sure why that is keeping Composer to open the app.

    Change the default app for the files to Composer in the Finder

    Fletcher

  7. Support Staff 7 Posted by Fletcher on 04 Dec, 2015 11:16 PM

    Fletcher's Avatar

    Also, in the terminal type "mdls filename.md" for one of your files, and
    send me the result. That might help me figure out which app it is.

    Thanks,

    Fletcher

  8. 8 Posted by francesco.cavig... on 05 Dec, 2015 11:44 AM

    francesco.caviglia's Avatar

    Changing the default app did not change the behaviour.
    MMD-Composer 3 started when I did a double-click, but did not open the file.
    And I still get “cannot open the file” when trying to open the file from inside the app.

    The result of “mdls filename.md” is the following:

    Francescos-MacBook-Pro:Dropbox Franz$ mdls prova.md
    kMDItemAlternateNames          = (
        "prova.md"
    )
    kMDItemContentCreationDate     = 2015-12-04 23:02:04 +0000
    kMDItemContentModificationDate = 2015-12-05 11:29:06 +0000
    kMDItemContentType             = "net.daringfireball.markdown"
    kMDItemContentTypeTree         = (
        "net.daringfireball.markdown",
        "public.plain-text",
        "public.text",
        "public.data",
        "public.item",
        "public.content"
    )
    kMDItemDateAdded               = 2015-12-05 11:35:55 +0000
    kMDItemDisplayName             = "prova"
    kMDItemFSContentChangeDate     = 2015-12-05 11:29:06 +0000
    kMDItemFSCreationDate          = 2015-12-04 23:02:04 +0000
    kMDItemFSCreatorCode           = ""
    kMDItemFSFinderFlags           = 16
    kMDItemFSHasCustomIcon         = (null)
    kMDItemFSInvisible             = 0
    kMDItemFSIsExtensionHidden     = 1
    kMDItemFSIsStationery          = (null)
    kMDItemFSLabel                 = 0
    kMDItemFSName                  = "prova.md"
    kMDItemFSNodeCount             = (null)
    kMDItemFSOwnerGroupID          = 20
    kMDItemFSOwnerUserID           = 501
    kMDItemFSSize                  = 1343
    kMDItemFSTypeCode              = ""
    kMDItemKind                    = "Markdown document"
    kMDItemLastUsedDate            = 2015-12-05 11:37:34 +0000
    kMDItemLogicalSize             = 1343
    kMDItemPhysicalSize            = 8192
    kMDItemUseCount                = 6
    kMDItemUsedDates               = (
        "2015-12-04 23:00:00 +0000"
    )
    Francescos-MacBook-Pro:Dropbox Franz$ /Users/Franz/Dropbox/

    I hope this tells you something.
    Thank you for your help
    Francesco

  9. Support Staff 9 Posted by Fletcher on 08 Dec, 2015 03:36 PM

    Fletcher's Avatar

    Are you absolutely certain that you are running 3.0b39 and not an older version?

    That error should have been fixed months ago -- I rewrote how Composer validates document types so that it basically says "Yes" to everything.

    That error message in particular, though, only occurs when that UTI (in this case 'net.daringfireball.markdown') doesn't conform to 'public.text'). Which, according to the mdls output above, it does.

    Some other application that handles Markdown seems to be messing up the UTI tree on your computer. Unfortunately, there is no way to say "Use this one before you use that one." The only solution is to delete the potential offending applications, and then try adding them back later.

    It seems that the OS X sort of uses a "first come, first serve" approach, but I can't guarantee that.

    But I definitely didn't change anything related to that recently (months??) and your document opens just fine on my machine.

    Fletcher

  10. 10 Posted by francesco.cavig... on 08 Dec, 2015 03:59 PM

    francesco.caviglia's Avatar

    Hi Fletcher,
    that’s great, I deleted Haaropad and (with a bit more reluctance) Byword, and now I can open my file.
    Thanks a lot!
    Francesco

  11. Support Staff 11 Posted by Fletcher on 08 Dec, 2015 04:14 PM

    Fletcher's Avatar

    You should be able to add Byword back and try again (reboot before and after to be safe).

    I have Byword installed on my machine with no problems. I have not used Haaropad.

    Glad it's working now!!

    F-

  12. Fletcher closed this discussion on 08 Dec, 2015 04:14 PM.

  13. francesco.caviglia re-opened this discussion on 13 Jan, 2016 03:16 PM

  14. 12 Posted by francesco.cavig... on 13 Jan, 2016 03:16 PM

    francesco.caviglia's Avatar

    I got a parser error (Version 3.0b41 - non sandboxed), see file

    Than I found a small bug in the spell-checker:
    - if I make a mistake with an accented character or one of the Scandinavian
    characters ( æ ø å ), the correct word does not show up as a suggestion

    See here case 1 (i make a mistake with standard characters in
    “forudsætning”, and the spell checker suggests the correct word)

    See here case 2 (I do not write the ‘æ’ and get “no guesses found”):

    Thanks for a great product
    Francesco

    —-

  15. Support Staff 13 Posted by Fletcher on 13 Jan, 2016 11:32 PM

    Fletcher's Avatar

    Thanks for the parser error file, I’ll look at it.

    The spell checker is OS X — you’ll have to talk to Apple about problems with it.

    Thanks!!

    Fletcher

    --
    Fletcher T. Penney
    Manager, Founder
    MultiMarkdown Software, LLC
    [email blocked]

  16. Support Staff 14 Posted by Fletcher on 30 Jan, 2016 11:55 PM

    Fletcher's Avatar

    The parser error is fixed for the next release.

    Thanks!

    F-

  17. 15 Posted by francesco.cavig... on 01 Feb, 2016 01:09 PM

    francesco.caviglia's Avatar

    You are welcome Fletcher, thanks for fixing it!

    I am using MMC for any slightly longert writing and am quite happy.

    There is one thing that could work better:
    I am now using the TOC more and more, but when I rearrange headings using
    the TOC interface it often happens that a level 1 heading ends up as a
    level 2 subheading instead of staying at level 1.
    I see that I should put extra care in releasing the mouse as far to the
    left as possible to avoid the problem, but this is quite unnatural. I think
    that when you move a header, the header with belonging sub-headers should
    by default keep its place in hierarchy. Going one step down or up in
    hierarchy should be a different operation that is separate from moving the
    heading to a different place.
    Or at least you should get a better visual cue of where you are placing
    your heading.
    Just my 3 cents ;-)
    At any rate, back in the late ‘80s, it took years before Microsoft got
    their Word-outline to work smoothly, so I can wait…

    A minor thing, that might depend on external libraries and has an easy
    work-around:
    while “copy to html” works a charm, “copy to RTF” is less precise in
    handling bulleted lists.
    Right now I copy to html, paste the result into http://www.html-cleaner.com
    and then copy the RTF.

    Best
    Francesco

    —-
    Francesco Caviglia
    Hejdesvej 10A
    8270 Højbjerg

  18. 16 Posted by francesco.cavig... on 11 Feb, 2016 08:47 AM

    francesco.caviglia's Avatar

    Hi Flecther,
    just found a bug.

    This link
    https://it.wikisource.org/wiki/Cuore_(1889)/Ottobre/Il_ragazzo_calabrese

    isn’t parsed or pasted correctly, the link stops at …1889
    when you paste it:

    the same link works fine between <angled brackets>.

    Keep up the great work, I love Multimedia Composer!
    Francesco

    —-
    Francesco Caviglia
    Hejdesvej 10A
    8270 Højbjerg

  19. Support Staff 17 Posted by Fletcher on 11 Feb, 2016 02:12 PM

    Fletcher's Avatar

    Can you send the document you're using? That link works fine for me.

  20. Fletcher closed this discussion on 19 Sep, 2017 05:47 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac