Pro Purchase won't "stick" on Mac with iCloud disabled (work restriction)

Brady Rosino's Avatar

Brady Rosino

28 Sep, 2017 01:20 AM

Hello, Today I purchased MultiMarkdown Composer 4 Pro package and it works fine on my personal laptop... but when I installed it on my work laptop I am having issues.

Installs fine and if I go to "restore purchases" I get a message saying my purchase has been restored and it tells me to restart the app. I restart the app and it is still in basic mode. Is this a possible problem with iCloud restrictions on my mac? I'm signed in to the same apple account both in system prefs / iCloud and also on the mac app store. For whatever reason, the purchase restore just won't stick.

Any help/guidance would be appreciated. I purchased the app for 99% usage only on my work Mac.

  1. 1 Posted by Brady Rosino on 28 Sep, 2017 01:27 AM

    Brady Rosino's Avatar

    Just took asking for help... Tried deleting the app... the reinstalled the app... then it just worked. Didn't even need to restore purchase, it just launched in to pro mode on first launch following reinstall.

    For future troubleshooting... I may have created the original problem for myself by doing this.

    Purchased on Mac 1 with apple id A configured in both system prefs and app store.

    Installed on Mac 2 with apple id B (work email) in system prefs and apple id A in mac app store (restore says it is successful, but it does not actually work)

    Then I changed system prefs apple id to apple id A so that it was app id A in both system prefs and also mac app store (still did not work)

    Reinstalled with apple id already in place in system prefs and mac app store... this fixed it.

    Hope it might help someone in the future.

  2. Support Staff 2 Posted by Fletcher on 28 Sep, 2017 01:41 AM

    Fletcher's Avatar

    Sorry you’re having trouble. Multiple people have reported trouble with the App Store on their computers. *Most*, not all, of the time, rebooting the computer seems to help. You may have to try to restore purchases again.

    If that doesn’t work, try deleting the App and downloading it again.

    Last resort:
    Find your App Store version of Composer
    In the Finder, right click on Composer and choose “Show Package Contents”
    Open the “Contents” folder.
    Inside the “_MASReceipt” folder is a file named “receipt”
    Email that file to me at <[email blocked]>
    That will allow me to validate that the App Store is sending the proper receipt. Thus far, no one has found a problem with Composer not properly validating the receipt. It’s always been an App Store issue. But there's a first time for everything...

    F-

  3. Fletcher closed this discussion on 28 Oct, 2017 08:23 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac