Unicode characters mangled in HTML export

BobTodd's Avatar

BobTodd

18 Jan, 2018 06:56 PM

Howdy y'all,

I'm new to using MultiMarkdown Composer, so if I'm simply overlooking a built-in feature, I apologize.

I was creating a Markdown document where I wrote the following:

That is, if the Old Saxon lessons will represent the sound [ð] by the glyph 'đ' (Latin Small Letter D with stroke, U+0111), then the appropriate uppercase counterpart is 'Đ' (U+0110) and not 'Ð' (U+00D0).

I then exported the document to HTML (to make sure I was using document links correctly), and I noticed that this sentence was rendered as follows:

That is, if the Old Saxon lessons will represent the sound [ð] by the glyph 'đ' (Latin Small Letter D with stroke, U+0111), then the appropriate uppercase counterpart is 'Đ' (U+0110) and not 'Ð' (U+00D0).

That is, all the non-ASCII Unicode characters got mangled. This happens throughout the document. Is there a way to ensure that MMD Converter preserves the Unicode characters correctly?

Thanks for any help you can offer.

Peace out,
Todd

  1. Support Staff 1 Posted by Fletcher on 18 Jan, 2018 07:50 PM

    Fletcher's Avatar

    Todd,

    Without seeing your entire document, I can only guess.

    But my suspicion is that you're only creating an HTML "snippet", not a
    complete document. To be complete, HTML requires the `<!DOCTYPE
    html><html><head>...` portion. Without that your browser does not know
    what character encoding should be used.

    The easiest way to do this in MMD is to add metadata at the top -- this
    forces a complete document, and allows you to set the title (which is
    technically required in HTML):

    Title: Some Title

    Your text here

    You can also use the preferences to force a complete document without
    using metadata. (The command line has options for this as well.)

    Hope this helps!

    Fletcher

  2. 2 Posted by BobTodd on 18 Jan, 2018 08:06 PM

    BobTodd's Avatar

    Howdy Fletcher,

    Wow. Spot on! Now I understand the "Force 'snippet'" and "Force 'complete' document" preference options. Thanks so much for the clarification.

    You rock!

    Peace out,
    t

  3. Fletcher closed this discussion on 25 Jan, 2018 05:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac