The only Theme which "sticks"at MMC4 launch is Pretentious

marcelo.marchetti's Avatar

marcelo.marchetti

23 Dec, 2019 07:16 PM

Version: 4.5.12 (104)
Steps:
1. Open Preferences
2. In Preview section, select CriticMarkup for Default Preview CSS from Pretentious
3. Restart MMC: the Pretentious CSS is used instead of the selected CriticMarkup
4. Open Preferences again, the Default Preview CSS indicates that CriticMarkup is selected...

I removed the preferences (PL) file in the Containers folder (under Library/Application Support) to no avail. Something that I am doing wrong?

  1. Support Staff 1 Posted by Fletcher on 21 Jan, 2020 01:32 AM

    Fletcher's Avatar

    I'm sorry for missing this in my inbox.

    The preferences set the default CSS/Theme. If you have chosen different ones for a particular file, you would have to change the settings for that file in the menu bar.

    Fletcher

  2. 2 Posted by marcelo.marchet... on 21 Jan, 2020 01:45 AM

    marcelo.marchetti's Avatar

    Hi Fletcher,

    Thanks for your reply. Please note the Preferences where I have selected a theme called “Github_SSeF_SCP”.

    However, the Preview page shows the Default theme per below.

    Only by manually selecting the theme “Github_SSeF_SCP” from the menu [View>Preview CSS>Github_SSeF_SCP], I get the desired preview per below. I do not know what I am doing incorrectly when setting the default Preview CSS in the Preferences panel.

    Thanks,

    Marcelo

  3. Support Staff 3 Posted by Fletcher on 21 Jan, 2020 02:49 AM

    Fletcher's Avatar

    The preferences set the *default* theme/css. You can override them on a
    per file basis with the menu bar. Changing the default does not change
    the overridden theme for a specified file once you have applied a custom
    theme to the file. Each document can have its own theme/css and
    Composer remembers your preference for each file.

  4. 4 Posted by Martzell on 12 Feb, 2020 09:54 AM

    Martzell's Avatar

    Hello Fletcher,

    Multimarkdown Composer never shows the preview css correct, see screenshot. I've removed the app completely, with preferences and supporting files, and reinstalled, but problem persists. Also if I switch preview theme manually via menu "View" the only preview theme that works is Pretentious. After restart the setting is lost, even when the md file is saved… wait, I've hit cmd s again after switching preview theme and it shows the Pretentious css also after restart of the app, but in menu "Preview Theme" still "GitHub" has the checkmark.

    Is there a known problem?

    Mac OS Mojave 10.14.6 (18G3020) on MacBook Pro 15" 2015.

    Best regards, Martin

  5. 5 Posted by Ian on 08 Apr, 2020 06:51 PM

    Ian's Avatar

    I am having the same problem. Every time i open a file, the preview pane shows what looks like a generic css rendering. under the view menu, my preferred GitHub is selected, so I have to select another style, then go to the menu one more time to re-choose the GitHub style for it to display correctly. This is every time I launch MMDC.

  6. 6 Posted by regan on 18 Apr, 2020 02:38 AM

    regan's Avatar

    I am having the same issue. MMDC appears to be always showing a generic rendering regardless of the initial GitHub setting. The only way to change is to do as Ian described above.

  7. Support Staff 7 Posted by Fletcher on 18 Apr, 2020 12:20 PM

    Fletcher's Avatar

    I have begun work on porting the new text engine and preview engine (currently used in nvUltra) into Composer, which refactors and improves many aspects of the text editor and preview, including this issue.

    More to come!

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac