HTML audio doesn’t work in the preview mode

sup3rny4nb0y2's Avatar

sup3rny4nb0y2

29 Sep, 2019 06:15 PM

Hi!

HTML <audio> tag doesn’t work when your files are in a Dropbox/iCloud folder. It renders well in the preview mode, but does not play and shows “Error”.

I’m running MultiMarkdown Composer 4.5.12 on macOS Mojave 10.14.6.

Marked 2 doesn’t have this problem.

  1. Support Staff 1 Posted by Fletcher on 30 Sep, 2019 07:06 PM

    Fletcher's Avatar

    Add a fake link to an image (e.g. <img src="test.png" alt="" />) and then close and reopen the file. This should cause Composer to ask you to allow permission to access the entire folder (and not just the actual file you opened).

    If this is a sandboxing issue, that should fix it.

    If not, then let me know. I don't intentionally disable audio support in the preview, but that is not necessarily a supported feature either.

    Fletcher

  2. 2 Posted by sup3rny4nb0y2 on 01 Oct, 2019 03:50 PM

    sup3rny4nb0y2's Avatar

    No, unfortunately it’s not a sandboxing issue :< I gave the program full access to my disk in the macOS settings menu, but it din’t help.

    I know it’s a specific request, and I personally can use Marked after all, but it would be great if there was no such problem. Native HTML audio is a great help when taking notes on phonetics, music, physical acoustics, etc.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Screenshot_2019-09-30_at_01.06.13.png 445 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac