Confused, won't let me just cancel out of a document, see screenshots in zip file

ian's Avatar

ian

06 Dec, 2017 03:10 PM

It gets stuck in a "loop" so I can't exit if I decide to not save my edits.

  1. Support Staff 1 Posted by Fletcher on 06 Dec, 2017 04:37 PM

    Fletcher's Avatar

    I'll look at it this evening after work.

    So that I can properly troubleshoot:

    1. Do you have the auto save file preference enabled?

    2. Is the file being changed by any other application while open?

    3. Is the file in your iCloud documents folder, a Dropbox folder, or anything like that?

    4. What version of macOS are you using?

    Thanks,

    Fletcher

    Sent from my iPhone

  2. Support Staff 2 Posted by Fletcher on 07 Dec, 2017 12:34 AM

    Fletcher's Avatar

    When I try it, it seems to work as expected. The "Revert", "Cancel", and "Save" all seem to function as expected.

    The appearance of the "Revert" button does imply that the macOS auto save behavior is enabled.

    Let me know more details about exactly what is not working as expected.

    Thanks!

    Fletcher

  3. 3 Posted by ian on 07 Dec, 2017 04:09 PM

    ian's Avatar

    I'm trying to reproduce it step-by-step. Now I'm getting confused about auto-save. I have it enabled, but now if I close the file, or exit Multimarkdown after making changes I don't get any prompts and my edits are not saved? I tried with a file on Dropbox and also stored locally. The same behaviour.

    What is supposed to happen?
    Thanks

  4. Support Staff 4 Posted by Fletcher on 08 Dec, 2017 12:29 AM

    Fletcher's Avatar

    Auto save is implemented by macOS, not by Composer.

    Auto Save is *supposed* to cause the OS to periodically trigger a save
    action on the document if it has been changed.

    If this is enabled, and you close a document that has been edited, it
    *should* trigger a save before closing.

    The main danger of this is saving a change that you in fact did not want
    to save. Which is why Composer allows you to turn this function off.
    (I don't like this feature myself, so I tend to keep it disabled).

    *NOTE*: This behavior can also be disabled in the "General" system
    preferences

    In my testing on 10.12 and 10.13, it works as expected.

    Have you tried rebooting your computer? I've seen various users with
    very odd behavior on their computers that is fixed with a reboot.
    Perhaps the quality of macOS is not quite what it used to be.

    F-

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Archive.zip 201 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac