System thinks MMC4 is running when it's not

essin's Avatar

essin

02 Dec, 2017 07:27 PM

Hi,
When I tried to install that latest update from the app store it said that MMC was running and did I want to kill it before proceeding. Also Keyboard Maestro thought MMC was running. Login in the activity monitor, there was no indication that it was, in fact, running.

I'm confused. Is there some subtle thing I'm missing?

Thanks

  1. Support Staff 1 Posted by Fletcher on 02 Dec, 2017 08:19 PM

    Fletcher's Avatar

    Nothing special on my end. Probably just need to reboot.

    Fletcher.

    Sent from my iPhone

  2. 2 Posted by essin on 02 Dec, 2017 09:10 PM

    essin's Avatar

    Thanks, There must be something up with high sierra. This is the third
    suggestions that I've received (different apps) to reboot as the
    solution to a problem. Apparently all sorts of stuff is remaining in
    cache after apps terminate.

  3. Support Staff 3 Posted by Fletcher on 02 Dec, 2017 09:47 PM

    Fletcher's Avatar

    I've learned from supporting my customers that:

    1. Even macs need rebooting periodically.

    2. "Wipe and reinstall" is still a good strategy for upgrading your Mac.

    F-

    Sent from my iPhone

  4. 4 Posted by essin on 03 Dec, 2017 12:01 AM

    essin's Avatar

    Sure, but Wipe and reinstall is great if you only have one app installed
    and your life consists of grooming the system instead of using it.

    Periodic reboots are good but if there are memory leaks causing the
    trouble they may get you when you least expect it since they are
    situational, not just a function of time.

    btw - I just thought it might help you to know. I didn't and don't
    expect you do to anything else but thanks for the support. I really
    appreciate your effort.

    Thanks,

    Dan

  5. Support Staff 5 Posted by Fletcher on 03 Dec, 2017 05:42 PM

    Fletcher's Avatar

    Definitely happy to help, but it is frustrating when there are problems
    that are out of my control and I have no useful advice to offer.

    *Especially* in some cases where it is 99% likely that it is out of my
    control, but there is a slim chance that there is a problem on my end
    that does need to be fixed. I don't want to turn a blind eye to
    something that is my fault.

    F-

    PS> I assume you tried Cmd-Opt-Esc to Force Quit and see if a zombie
    process was running?

  6. 6 Posted by essin on 03 Dec, 2017 06:04 PM

    essin's Avatar

    Thanks again.

    The only thing I didn’t try was a ps -a. It skipped my mind at the time

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac