Unable to open document created with MMC

Marcelo Machetti's Avatar

Marcelo Machetti

25 Dec, 2018 09:58 PM

MacOS: Mojave 10.14.2, but also seen with High Sierra
Product: MMC 4.5.1 (87)
Version: 4.5.1

Steps to reproduce:

1. Lauch MMC
2. Select [New Document}
3. Enter text "This is the text."
4. Select File > Save
5. In dialog box enter "Text", accept standard .mdd extension
6. Select File > Quit
7. Relaunch MMC
8. From the DB, note that the "Text.mdd" document is not associated to MDD - the icon is generic (file attached)
9. Select "Text.mdd" and click "Open"
10. A DB is presented to the user stating "The document “Text.mdd” could not be opened."

Note that the document. can be opened with a regular text editor or Textedit without error. The only option to create new document is to open a version 3 document in 4.5.1 and rename it... Is it possible to downgrade to version 3?

Thanks,

Marcelo Marchetti

  1. 1 Posted by Marcelo Machett... on 25 Dec, 2018 10:15 PM

    Marcelo Machetti's Avatar

    Note that creating the document with BBEdit and saving with MMD extension, all works fine, including the correct icon association.

  2. Support Staff 2 Posted by Fletcher on 26 Dec, 2018 12:18 AM

    Fletcher's Avatar

    Marcelo,

    Sorry you're having trouble. That's unusual.

    1. You say that you use the extension "mdd". I assume you meant to type "mmd"? "mdd" is not an extension used by Composer.

    2. Assuming you meant "mmd", use the Terminal to run `mdls yourfilename.mmd` with one of your files. Send me a copy of the results. You should get something like this:

    kMDItemContentType = "net.daringfireball.markdown"
    kMDItemContentTypeTree = (
        "net.daringfireball.markdown",
        "public.item",
        "public.text",
        "public.data",
        "public.content",
        "net.daringfireball.markdown",
        "public.plain-text"
    )

    If you have another program that is modifying the UTI system incorrectly, it could cause the file to not be openable by Composer. The `mdls` command can help offer information about what macOS *thinks* the file is.

    Let me know what you find, and we can go from there.

    Fletcher

    --
    Fletcher T. Penney
    Manager, Founder
    MultiMarkdown Software, LLC
    [email blocked]

  3. 3 Posted by Marcelo Marchet... on 26 Dec, 2018 12:41 AM

    Marcelo Marchetti's Avatar

    Apologies, I meant .mmd… To make sure that I was not doing this myself, I reopened MMC and created a new doc. I noticed that when saving a file the extension mdd is added automatically. See the picture I am enclosing. This is what happens by default.

    However, if I re-select [MultiMarkdown Text Document] in the File Format drop down list, the extension is now set to .md instead of .mmd as per the picture below.

    I followed up on your request in point 2 below with Terminal and the output is pasted below. I think that the issue is that MMC is picking *.mdd instead of *.mmd by default or *.md.

    Regards,

    Marcelo

    kMDItemContentCreationDate = 2018-12-26 00:29:51 +0000
    kMDItemContentCreationDate_Ranking = 2018-12-26 00:00:00 +0000
    kMDItemContentModificationDate = 2018-12-26 00:29:51 +0000
    kMDItemContentType = "net.multimarkdown.text"
    kMDItemContentTypeTree = (
        "net.multimarkdown.text",
        "public.text",
        "public.data",
        "public.item",
        "public.content",
        "public.plain-text"
    )
    kMDItemDateAdded = 2018-12-26 00:29:51 +0000
    kMDItemDateAdded_Ranking = 2018-12-26 00:00:00 +0000
    kMDItemDisplayName = "Testing with Fletcher....mmd"
    kMDItemFSContentChangeDate = 2018-12-26 00:29:51 +0000
    kMDItemFSCreationDate = 2018-12-26 00:29:51 +0000
    kMDItemFSCreatorCode = ""
    kMDItemFSFinderFlags = 0
    kMDItemFSHasCustomIcon = (null)
    kMDItemFSInvisible = 0
    kMDItemFSIsExtensionHidden = 0
    kMDItemFSIsStationery = (null)
    kMDItemFSLabel = 0
    kMDItemFSName = "Testing with Fletcher....mmd"
    kMDItemFSNodeCount = (null)
    kMDItemFSOwnerGroupID = 20
    kMDItemFSOwnerUserID = 504
    kMDItemFSSize = 25
    kMDItemFSTypeCode = ""
    kMDItemInterestingDate_Ranking = 2018-12-26 00:00:00 +0000
    kMDItemKind = "MultiMarkdown Text Document"
    kMDItemLastUsedDate = 2018-12-26 00:29:51 +0000
    kMDItemLastUsedDate_Ranking = 2018-12-26 00:00:00 +0000
    kMDItemLogicalSize = 25
    kMDItemPhysicalSize = 4096
    kMDItemUseCount = 3
    kMDItemUsedDates = (
        "2018-12-25 05:00:00 +0000"
    )
    kMDItemUserCreatedDate = (
        "2018-12-26 00:29:51 +0000"
    )
    kMDItemUserCreatedUserHandle = (
        504
    )

  4. Support Staff 4 Posted by Fletcher on 26 Dec, 2018 12:52 AM

    Fletcher's Avatar

    Did you change the Files preferences? Composer won't pick `mdd` unless you tell it to. It's not an extension that Composer "knows."

    So if you change the extension to "md" (or "mmd"), does it open properly? The mdls information that you included suggests that the file you included information from is working correctly. The "net.multimarkdown.text" Content Type is the right one, and you can see below that the "public.plain-text" which means that macOS knows this is a text file (because of the UTI that Composer provided.) The filename of "Testing with Fletcher....mmd" suggests that "mmd" (not "mdd") should work.

    Fletcher

    PS> FYI the "known" extensions that Composer uses are md, txt, mmd, mdown, markdn, markdown, text, ft

    --
    Fletcher T. Penney
    Manager, Founder
    MultiMarkdown Software, LLC
    [email blocked]

  5. 5 Posted by Marcelo Marchet... on 26 Dec, 2018 12:57 AM

    Marcelo Marchetti's Avatar

    I did not change the file preferences — at least not knowingly but it is probably that I must have done it. I reset the preferences to “mmd” and order is restored… Thank you for bearing with me. I think that the mystery is resolved.

    Thanks,

    Marcelo

  6. 6 Posted by Marcelo Marchet... on 26 Dec, 2018 01:31 AM

    Marcelo Marchetti's Avatar

    One last question: what is the extension for MMC? *.mmd or *.md? My MMC seems to be using both.

  7. Support Staff 7 Posted by Fletcher on 26 Dec, 2018 01:57 AM

    Fletcher's Avatar

    I had double checked the code, and I don't see any way that Composer could have entered mdd into the file preferences without the user doing it. Never say never, and all that. But I don't see how it's possible.

    Glad that did the trick! Let me know if you have any further trouble!

    Fletcher

    --
    Fletcher T. Penney
    Manager, Founder
    MultiMarkdown Software, LLC
    [email blocked]

  8. Support Staff 8 Posted by Fletcher on 26 Dec, 2018 01:58 AM

    Fletcher's Avatar

    Technically it doesn't matter. Some prefer one, some prefer the other. It will work with any extension that maps to a text file via a valid UTI.

    The built in ones are md, txt, mmd, mdown, markdn, markdown, text, ft

    F-

    --
    Fletcher T. Penney
    Manager, Founder
    MultiMarkdown Software, LLC
    [email blocked]

  9. Fletcher closed this discussion on 04 Jan, 2019 03:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac