Unable to write accented characters

Juan José Torrens's Avatar

Juan José Torrens

27 Nov, 2017 10:26 PM

The update that introduces key bindings, i.e. version 4.2.0 (68), seems to block the use of accented characters in words like camión, árbol or paragüero, which in previous versions could be correctly written. The attached screen capture shows a window of MMDC and another of TeXShop. The words in both windows have been written using the same keystrokes.

Best regards

Juan José

  1. 1 Posted by Juan José Torre... on 28 Nov, 2017 12:01 AM

    Juan José Torrens's Avatar

    A close inspection shows that the problem comes from the fact that two keys are blocked.They have no effect. I attach an image of an Spanish keyboard. The concerned keys are those colored in orange: alone or modified with the shift key, they serve to write characters like áàâä. Modified with the option key, they provide the characters { and [, that now I am also unable to write.

    Best regards

    Juan José

  2. Support Staff 2 Posted by Fletcher on 29 Nov, 2017 02:42 AM

    Fletcher's Avatar

    Juan José,

    Unfortunately various keyboards make different use of special keys that can lead to problems like this.

    If you modify the default.keybinding file (more information is here), you can change the key commands for anything that uses { or [. This should fix your problem, and also allow you to use alternative shortcuts for those commands (if desired).

    Let me know what you think a good replacement would be, and I can share another default file with others who use Spanish keyboards.

    Thanks!!

    F-

  3. 3 Posted by Aslak Raanes on 29 Nov, 2017 11:39 AM

    Aslak Raanes's Avatar

    The same problem applies to Norwegian keyboard, which means that I now longer can write backticks directly (using option+´ ), or write combination characters with ´, `, ~, ¨, ^

  4. 4 Posted by Juan José Torre... on 29 Nov, 2017 06:28 PM

    Juan José Torrens's Avatar

    I have not been able to solve it. I have done many tests without success. For example, in default.keybinding, I have replaced

    key": "{",
    "action": "decreaseLine:",
    "modifiers": ["cmd", "shift"]
    }
    
    by
    key": "Y",
    "action": "decreaseLine:",
    "modifiers": ["cmd", "shift"]
    }
    
    But that does not release the ´ key (acute accent key) and so option+´, which yields {. Hence, I am still unable to write {, [ and accented characters. Here are some thoughts:
    1. The preceding message by Aslak shows that the problem is more general, not limited to Spanish keyboards.

    2. Even if I could solve the issue by modifying default.keybinding, the problem would still remain for users of the free and standard versions, since it seems that changes in keybindings is a pro feature.

    3. A user expects to be able to write any text without doing any special configuration. By default, if a user hits, for example, ´ and then a, it should yield á right out of the box.

    4. Keybinding may be interesting for some users, but not too much for others, like me. I use a reduced number of shortcuts, since I find it difficult to remember them. There are too many (those in MMDC, TeXShop, OS X, etc.). I prefer meaningful expressions. This is why text expansion is much more useful for me. And even more simple for text insertion. E.g., this example can be more easily done with text expansion:

      {
       "key" : ".hc",
       "expansion" : "<!--%replaced-->"
      }
      
      Here .hc stands for HTML comment.

    Best regards

    Juan José

  5. Support Staff 5 Posted by Fletcher on 30 Nov, 2017 02:15 AM

    Fletcher's Avatar

    I dug into it more and found the issue. It actually has nothing to do with the key-binding code, but rather a nearby change that "unprotected" a call that had previously been wrapped in a check for invalid values.

    Fixed for next release.

    Thanks!

    F-

  6. Fletcher closed this discussion on 30 Nov, 2017 02:15 AM.

  7. Juan José Torrens re-opened this discussion on 01 Dec, 2017 04:43 PM

  8. 6 Posted by Juan José Torre... on 01 Dec, 2017 04:43 PM

    Juan José Torrens's Avatar

    I just confirm that the problem has been solved in MMDC version 4.2.2 (69).

    Many thanks

    Juan José

  9. Support Staff 7 Posted by Fletcher on 01 Dec, 2017 04:51 PM

    Fletcher's Avatar

    Great! Glad it's working and thanks for letting me know!

  10. Fletcher closed this discussion on 01 Dec, 2017 04:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac