Pro Purchase still broken with 4.01 in the US

Moritz Berger's Avatar

Moritz Berger

18 Sep, 2017 10:50 PM

I tried this 7 times ...
1. install 4.01
2. click on Pro Upgrade

-> Best case: asks for App Store password or Touch ID. Then nothing
-> In the same session, or if button is clicked multiple times, even that password prompt doesn't appear anymore (missing semaphore?)

Tried mitigation: Reboot, Uninstall and Reboot, ...

  1. 1 Posted by Steve Glaser on 18 Sep, 2017 11:26 PM

    Steve Glaser's Avatar

    Somewhat similar problem here. Upgrade doesn't work.

    This time, I get US prices and a Purchase button just fine. Clicking Purchase pauses and then causes the App Store to report a 403 error. The 403 error dialog box has Cancel and Retry buttons -- these work as expected but Retryreports another 403 error.

  2. Support Staff 2 Posted by Fletcher on 18 Sep, 2017 11:28 PM

    Fletcher's Avatar

    Moritz,

    Unfortunately this appears to be an Apple issue -- there's not anything I can do about troubleshooting the App Store.

    I put what I could find in my research here:

    http://support.multimarkdown.com/discussions/problems-v4/20-app-sto...

    The link mentioned in that page makes some suggestions about ways to reset the App Store cache. Also some other things to check on.

    This sounds like a slightly different App Store issue, but perhaps the suggested remedies could still help.

    Wish I could do more to help with the App Store issues, but you know how transparent Apple is.....

    Do you have another machine that is not running High Sierra? Perhaps trying there?

    Fletcher

  3. Support Staff 3 Posted by Fletcher on 18 Sep, 2017 11:29 PM

    Fletcher's Avatar

    Steve -- the 403 error is described on that other page, and is definitely an Apple problem, not a "Fletcher" problem.

    The suggestions there may be helpful.

    (More correctly, I should say it is a "Fletcher" problem in that it is frustrating for me to hear from frustrated customers when there's nothing I can do to solve their problem for them. And frustrating when people are unable to use my application when they're trying to. But seems to be an issue triggered by causes outside of my control.)

  4. 4 Posted by Moritz Berger on 19 Sep, 2017 12:25 AM

    Moritz Berger's Avatar

    Workaround (purchase still didn’t go through on the machine I first tried, running High Sierra GM) - bought Pro on a Sierra machine. Subsequent “restore purchase” worked alright on the High Sierra machine - which solves the problem for me, for now (until Markdown Composer 5.0 on Ultra Sierra or whatever …).
    Fletcher, thanks for your help and for being so responsive.

    On 18 Sep 2017, at 16:28, Fletcher wrote:

  5. Support Staff 5 Posted by Fletcher on 19 Sep, 2017 12:37 AM

    Fletcher's Avatar

    Moritz -- thanks for the update, and glad it's working!

  6. Fletcher closed this discussion on 20 Sep, 2017 12:27 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac