Smart Quotes

Brian Weatherson's Avatar

Brian Weatherson

26 May, 2018 04:01 PM

I upgraded to the latest version this morning, and since then I've been having a problem with smart quotes.

When I upgraded, the new version had the setting for Smart Quotes (in Edit>Substitutions) turned on. I previously had it turned off, but that's not a big deal. Upgrades sometimes change things like that.

The problem is that every time I re-open Composer, it defaults back to having Smart Quotes turned on, and I have to remember to turn it off again. Once I turn it off, it works fine. But it should remember this setting, shouldn't it? I'm pretty sure before the upgrade it did remember it.

  1. Support Staff 1 Posted by Fletcher on 26 May, 2018 04:20 PM

    Fletcher's Avatar

    Brian,

    There was a change that unfortunately got partially implemented in 4.4.2 and the rest will come in 4.4.3. The preferences to control the override of smart quotes (and dashes) will be available then.

    1. I actually don't recommend using the macOS smart quotes feature in the editor -- in MultiMarkdown, quotes can be displayed as smart quotes by MMD itself and remain "dumb" in the text file.

    2. That said, you can do what you want.... ;) Once 4.4.3 is released (soon), there will be preferences in the Editing section to control the default behavior.

    Thanks, and sorry for the difficulty. Should be fixed in the next release for you.

    Fletcher

  2. Fletcher closed this discussion on 26 May, 2018 04:20 PM.

  3. Brian Weatherson re-opened this discussion on 26 May, 2018 06:07 PM

  4. 2 Posted by Brian Weatherso... on 26 May, 2018 06:07 PM

    Brian Weatherson's Avatar

    Thanks! Glad to hear it’s under control.

    Brian

    Sent from my iPad

  5. Fletcher closed this discussion on 27 May, 2018 04:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac