Quotes, smart and otherwise

Vince's Avatar

Vince

13 May, 2018 12:18 AM

I had smart quotes turned on ("Enable smart quotes" checkbox in the "MultiMarkdown options" section of the "MMD" tab in Preferences). I needed some "dumb" quotes. I couldn't figure out how to get them. I turned off (unchecked) smart quotes. Typing quotes still gave me smart quotes. I quit the app completely, re-opened it, re-opened the file, typed quotes, still got smart ones.

So, two things.
1. Why isn't MMD respecting the checkbox?
2. If one has it checked, how does one get dumb quotes in a file when one needs them? I tried escaping them (\"), that didn't work. I also tried searching for "quotes" on the page where "Help/MultiMarkdown Composer Help" takes you, but saw nothing useful (most of the matches weren't about smart quotes at all, which is to be expected since I kept the search broad by searching just for "quotes").

  1. Support Staff 1 Posted by Fletcher on 13 May, 2018 01:01 AM

    Fletcher's Avatar

    Do you mean smart quotes in the preview? Or in the text editor?

    MultiMarkdown controls the preview, but your system controls the editor.

    If that's not the case let me know exactly what's going on.

    I'm out of town so probably can't dig into it until Monday.

    F-

    Sent from my iPhone

  2. 2 Posted by Vince Rice on 13 May, 2018 02:33 AM

    Vince Rice's Avatar

    My system? How is my system involved? I don't get smart quotes anywhere else. (I just checked Mail, BBEdit, and MacDown.) I get them in Word, but that's because Word has a setting specifically for that. Which is what I thought the MMD Preferences was.

  3. Support Staff 3 Posted by Fletcher on 13 May, 2018 03:43 AM

    Fletcher's Avatar

    Do you mean that you get smart quotes in the editor pane?

    Composer doesn't do that. Your system does.

    If you mean dumb quotes in the editor get turned to smart quotes in the preview despite turning off the check box - that's composer.

    F-

    Sent from my iPhone

  4. 4 Posted by Vince Rice on 13 May, 2018 07:47 PM

    Vince Rice's Avatar

    Yes, smart quotes in the editor pane. And, again, what are you talking about? As I said, I don't get smart quotes anywhere else (except a program that specifically has a setting for them).

  5. Support Staff 5 Posted by Fletcher on 13 May, 2018 08:51 PM

    Fletcher's Avatar

    macOS has settings for smart quotes. Check your preferences or you can also use edit menu to access them.

    Composer doesn't convert them.

    Sent from my iPhone

  6. 6 Posted by Vince Rice on 13 May, 2018 11:37 PM

    Vince Rice's Avatar

    As I've said twice now, if macOS has settings, no other program I have is using that setting. I don't know where this mysterious setting is, but it's irrelevant to everything else (that I have, anyway) on the Mac. Pages has a preference for smart quotes, for crying out loud. I'm not sure why MMD is using this mysterious setting, especially since MMD has a setting for smart quotes. That is past confusing.

    Whether or not we get smart quotes in MMD (on either side) should be controlled by MMD. Just like every other program* on the Mac.

    *Within two decimals of "every".

  7. Support Staff 7 Posted by Fletcher on 14 May, 2018 05:43 AM

    Fletcher's Avatar

    And as I've written twice, this is a macOS thing. It's not my fault if you don't know how to use your computer... ;) Google is your friend....

    Check the Keyboard preferences -- "Text" tab. That controls the default settings.

    But you can also override on a per-app as needed basis in the Edit Menu -- "Substitutions".

    MultiMarkdown has supported "smart quotes" long before macOS did, based off Gruber's SmartyPants project in 2002. That converts regular quotes/dashes/periods in MMD text to "smart" quotes, dashes, and ellipses in the HTML output, but does not modify the original text itself. Composer supports all of the MMD options in the "MMD" preferences pane.

    That, however, is distinct from any built-in macOS behavior that actually modifies your keystrokes (e.g. text replacement, or smart quotes, as in this case) to change the text that you type in the editor. Composer doesn't even have any code to convert " into , so it couldn't do it if it wanted to. (It can do the reverse, however, with the "Clean Up" -> "Smart typography" command)

    F-

  8. Support Staff 8 Posted by Fletcher on 16 May, 2018 04:36 PM

    Fletcher's Avatar

    Did you get the quote behavior on your machine straightened out?

    F-

  9. 9 Posted by Vince Rice on 18 May, 2018 03:53 PM

    Vince Rice's Avatar

    I've given you several examples that it is not a macOS thing. No other program I've tried on my Mac does this. MMD is the only one. I therefore don't care if there's a setting or what the setting is — nothing else on the Mac (that I've tried, which is almost a dozen programs at this point) uses it, including Apple's own software!

    But, this is one of those conversations we have that isn't going anywhere, so I gave up. I fixed my particular problem that day by using a different editor.

    Thanks (seriously) for the followup (the one after this message).

  10. Support Staff 10 Posted by Fletcher on 22 May, 2018 09:53 PM

    Fletcher's Avatar

    Just saw your post on 5/18 -- it was flagged as spam (not sure why) so I didn't see it until I just went through the spam folder.

    (Side note before either/both of us get distracted -- Composer for iOS is almost ready for beta testing. You had expressed interest in it before, so I wanted to make sure you knew. I'll have to set it up with Apple's TestFlight program once I'm ready (it's internal testing only right now, which doesn't require any review from them, but is limited to my devices.) I hope to have it ready either later this week, or in 2-3 weeks when I finish my next stretch at the hospital.)

    The quotes issue is a macOS thing -- did you look at the preferences I pointed you towards, or the Edit menu? It sounds like you didn't, but I can't help you if you won't follow my advice.... ;) I have no control over what other applications on your computer do, so I can't speak to that. But Apple's software does use it -- check the Edit menu->Substitutions and you can control it there. And again, Composer has no concept of how to turn a straight quote into a curly quote on its own, so it has to be coming from somewhere (macOS, TextExpander or some other extension?)

    The particular setting involved is described here:

    https://developer.apple.com/documentation/appkit/nstextview/1449258...

    I just went through the source code again don't see anywhere that I modify that functionality. It respects your system settings (with the caveat that changes in preferences take effect on new windows, but changes via the edit menu occur instantly). Also, if you have smart pairs turned on, then it blocks that function since it forces the insertion of two characters. So turn off smart pairs if you want to see the effect.

    I do agree that this seems to be a conversation that isn't going anywhere, but this time it's one where you're in the wrong (as best as I can tell from what you've told me). Please look at what I've pointed you to, and if you can find something more substantial to point me towards, I'm happy to look further and help you try to figure it out. This honestly sounds like something where you just need to learn about a feature of macOS you haven't used before. And if I am in the wrong, I definitely want to know so I can learn more, but so far there has been nothing to back that claim up beyond opinion....

    This feature works for me on every Apple app (with meaningful text views) that I've tried so far -- some easy ones being Notes, Messages, TextEdit, Mail to name a few. Third party text editors are probably not a good place to test, because many of them use custom text views/engines that don't support (on purpose or by accident) many of the built-in OS features. (Be sure to check both the Edit menu and the system preferences as both contribute to the final behavior seen by the user.)

    But saying "I don't care if there's a setting or what the setting is" doesn't seem to be a very productive way of solving your problem. And I say "your problem" because quotes work as desired for me (I get "dumb" quotes in Composer, and everywhere else since I keep this feature off), and no one else has written me to say that they have had any trouble with this. So, to the best of my knowledge, you are the only person on the planet dealing with this and a fix is above, which would bring the number to 0. And in this case, it sounds like 0 is better than 1.

    ;)

  11. 11 Posted by Vince Rice on 22 May, 2018 10:53 PM

    Vince Rice's Avatar

    Maybe it was judging on the basis of the argument. :)

    As near as I can tell, we've both thought the other was wrong on all our our non-productive discussions. That's what made them non-productive. :) This one isn't any different.

    First, to clear up some apparent confusion, this is no longer a discussion about what's generating the smart quotes, and hasn't been since your first reply. This is about the fact that MMD is using the setting and shouldn't be. In my head that was clear from my arguments, but apparently not; my apologies. (I'll tell you a story about tapping out music sometime…)

    The point you have ignored every in every reply is that no other editor I've tried (and I've tried a lot) uses that setting. I have given you a number of examples that either do not have a setting (e.g. MacDown, etc.), and do not generate smart quotes (regardless of the macOS setting), or that have their own software setting (Pages, Word, etc.) and generate smart quotes based on their internal setting, not on the macOS setting.

    Third-party editors are exactly the place to look, because, guess what — MMD is a third-party editor.

    Every other editor I use to edit files ignores that setting. MMD does not. That isn't a me problem.

    I don't care about the setting in this context because no other editor (I have) uses the setting. MMD is an editor. It shouldn't be using the setting. It should control it's own destiny, just like every other editor.

    But, this isn't any more productive this reply than it was last reply. :) I think I'm right. You think you're right. Obviously, neither of us are changing the other's mind. Let's now retreat to our neutral corners.

    Because I'm definitely interested in trying the iOS version. :)

  12. Support Staff 12 Posted by Fletcher on 22 May, 2018 11:15 PM

    Fletcher's Avatar

    > First, to clear up some apparent confusion, this is no longer a
    > discussion about what's generating the smart quotes, and hasn't been
    > since your first reply. This is about the fact that MMD is using the
    > setting and shouldn't be. In my head that was clear from my arguments,
    > but apparently not; my apologies. (I'll tell you a story about tapping
    > out music sometime…)

    I don't recall seeing that in any of your posts -- these are definitely
    two different discussions:

    1) WTF is causing these smart quotes that I didn't ask for?

    2) Composer is respecting my macOS preferences, and I don't want it to.

    However, if you understand where the quotes are coming from, then saying
    that Apple apps don't do the same behavior doesn't make sense, because
    they do (I have not looked at Pages, because the goal of Pages is
    different than other apps, and it uses a different approach to
    textviews). But it makes no difference to me how your computer works
    outside of Composer, and whether you understand it. I know how mine
    works, and that's what matters to me.

    > The point you have ignored every in every reply is that no other editor
    > I've tried (and I've tried a lot) uses that setting.

    I haven't ignored it, that point had not been made (in the context of an
    expressed understanding of where the quotes come from.)

    > I have given you a
    > number of examples that either do not have a setting (e.g. MacDown,
    > etc.), and do not generate smart quotes (regardless of the macOS
    > setting), or that have their own software setting (Pages, Word, etc.)
    > and generate smart quotes based on their internal setting, not on the
    > macOS setting.
    >
    > Third-party editors are exactly the place to look, because, guess what —
    > MMD is a third-party editor.

    > Every other editor I use to edit files ignores that setting. MMD does
    > not. That isn't a me problem.

    That is a matter of perspective. I get annoyed when apps don't respect
    my system preferences. The entire point of system settings is that they
    apply to the entire system. I choose defaults that make sense to me,
    and the apps I use respect them. This provides a consistent environment
    everywhere.

    But this (as opposed to where the quotes are coming from) *is* a matter
    of opinion.

    It's certainly possible to include a preference to override your system
    settings, and I don't have a problem doing that. Had you asked for that
    at the beginning, this could have been a very short discussion....

    ;)

    (And, BTW, some people do like using smart quotes in Composer -- either
    because they are non-English writers and prefer to see the quotes
    instead of using MultiMarkdown's language-specific smart quotes, or
    because they prefer to copy/paste from other programs. So simply
    defaulting to "off" for everyone won't work.)

    > I don't care about the setting in this context because no other editor
    > (I have) uses the setting. MMD is an editor. It shouldn't be using the
    > setting. It should control it's own destiny, just like every other editor.
    >
    > But, this isn't any more productive this reply than it was last reply.
    > :) I think I'm right. You think you're right. Obviously, neither of us
    > are changing the other's mind. Let's now retreat to our neutral corners.

    Except now I know what you think you're right about. Which is a huge
    improvement! So I definitely disagree with this last paragraph.

    > Because I'm definitely interested in trying the iOS version. :)

    Which, by the way, will have a similar preference because iOS 11 offers
    smart quotes, which I suspect many iOS users have enabled (I think it is
    enabled by default??) For now it's actually turned off altogether
    because I didn't have the preferences configured when I did that.

    I'll add you to the beta tester's list.

  13. 13 Posted by Vince Rice on 23 May, 2018 02:25 AM

    Vince Rice's Avatar

    > Which, by the way, will have a similar preference because iOS 11 offers
    > smart quotes, which I suspect many iOS users have enabled (I think it is
    > enabled by default??) For now it's actually turned off altogether
    > because I didn't have the preferences configured when I did that.
    >

    lol. As long as we don't have to have this conversation again.

    This is why this matters, why it matters for third-party editors more "built-in" apps (e.g. Notes, Mail, etc.), and why it especially matters for Markdown editors.
    Markdown, by definition, is for plain (ASCII) text. It was the whole point of its invention ("…allows you to write using an easy-to-read, easy-to-write plain text format"). Smart quotes (and em/en-dashes, and …) are not plain text. So, regardless of what else macOS is doing with smart quotes, any "third-party editor" should be controlling its own behavior, and most especially a Markdown editor.

    I don't ever want smart quotes in a Markdown document. I want smart quotes from a MD document, but not in it.
    That position is not unique to me. My (educated) guess is that it's a majority position, probably a vast majority position.
    We want plain text files, that's why we're using Markdown.

    Looking forward to the iOS version.

  14. Fletcher closed this discussion on 23 May, 2018 02:48 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac