lost work

essin's Avatar

essin

29 Oct, 2017 10:21 PM

I needed to logoff to kill a browser sessions and forgot that there were unsaved changes in MMC. It didn't prevent the logoff with a "save" dialog and, since it lacks a timed autosave, everything id did during the prior 45 minutes is gone. :(

  1. 1 Posted by essin on 29 Oct, 2017 11:38 PM

    essin's Avatar

    I can’t reproduce this so maybe it’s just a system glitch.

  2. Support Staff 2 Posted by Fletcher on 30 Oct, 2017 12:04 AM

    Fletcher's Avatar
    1. I'm sorry you lost data -- that's always frustrating, regardless of the cause.

    2. I think it is a system glitch. I just tried testing on my machine, and unless I make a decision about save/don't save in Composer, the logout fails to complete. Even in Composer, that behavior is controlled by the system. (As long as something strange
      didn't happen with the undo stack to make Composer think the document was saved already.)

    3. Composer allows you to enable/disable the built-in autosave functionality of macOS. I personally don't like it, but keeping auto save on will keep you from losing the last change (but can cause it to save when you're not ready...)

    If you find something else to provide more evidence that it is a Composer issue, please let me know.

    Fletcher

  3. Fletcher closed this discussion on 30 Oct, 2017 12:04 AM.

  4. Fletcher re-opened this discussion on 30 Oct, 2017 12:07 AM

  5. Support Staff 3 Posted by Fletcher on 30 Oct, 2017 12:07 AM

    Fletcher's Avatar

    Along these lines, I just discovered this preference that I never knew existed:

    http://osxdaily.com/2012/08/22/turn-off-auto-save-os-x/

    Now I can turn off auto save in all my applications!

  6. Fletcher closed this discussion on 30 Oct, 2017 12:07 AM.

  7. essin re-opened this discussion on 30 Oct, 2017 12:34 AM

  8. 4 Posted by essin on 30 Oct, 2017 12:34 AM

    essin's Avatar

    Thanks for the tip. I have tried to reproduce the problem but couldn’t. It must have been something flaky in the OS.

    I wonder if there is a way to configure the OS autosave interval. The only thing I could find suggested that it was 1 hour. Seems too long to provide much protection.

  9. Support Staff 5 Posted by Fletcher on 30 Oct, 2017 12:36 AM

    Fletcher's Avatar

    The auto save interval, to the best of my knowledge, is much shorter than that. I think it varies based on how active you are in editing the document, but I suspect on the order of a few minutes.

  10. Fletcher closed this discussion on 31 Oct, 2017 02:14 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac