Saving new files to txt

Loren's Avatar

Loren

17 Sep, 2017 10:26 PM

I've set File Preferences default extension from md to txt. New files are still being saved as md. Is there a way to fix this please?

Loren

  1. Support Staff 1 Posted by Fletcher on 17 Sep, 2017 10:43 PM

    Fletcher's Avatar

    Which version are you using? This works fine for me in v4.0

    F-

  2. 2 Posted by Loren Stephens on 17 Sep, 2017 10:50 PM

    Loren Stephens's Avatar

    Version 4.0 (52). Image of my settings. I just tested it again and the file saved as MultiMarkdown.

  3. Support Staff 3 Posted by Fletcher on 17 Sep, 2017 10:52 PM

    Fletcher's Avatar

    Can you send a picture of the save dialog, with the "Hide extension" box
    *unchecked*?

    I just tested again with the same settings as you and it worked fine.

    F-

  4. 4 Posted by Loren Stephens on 17 Sep, 2017 11:13 PM

    Loren Stephens's Avatar


    On Sep 17, 2017, at 3:52 PM, Fletcher <[email blocked]> wrote:

    // Please reply above this line 
    ================================================== 

    From: Fletcher (Support staff)

    Can you send a picture of the save dialog, with the "Hide extension" box 
    *unchecked*?

    I just tested again with the same settings as you and it worked fine.

    F-

    On Sun, Sep 17 at 03:50 PM PDT, Loren Stephens wrote:

    Version 4.0 (52). Image of my settings. I just tested it again and the file saved as MultiMarkdown.

    Having trouble reading this? View this discussion online: Saving new files to txt.

    Reply with #ignore to stop receiving notifications for this discussion.


  5. Support Staff 5 Posted by Fletcher on 17 Sep, 2017 11:17 PM

    Fletcher's Avatar

    Turn off the "Suggest filenames..." preferences.

    Looks like something is happening and it is including a newline before
    the file extension. Use the arrow keys to move right/down inside the
    file name box and you'll see what I mean.

    Is that right?

    On 9/17/17 7:13 PM, Loren Stephens wrote:
    > // Please reply above this line
    > ==================================================
    >
    > *From*: Loren Stephens <[email blocked]>
    >
    >
    >
    >> On Sep 17, 2017, at 3:52 PM, Fletcher
    >> <[email blocked]
    >> <mailto:[email blocked]>> wrote:
    >>

  6. 6 Posted by Loren Stephens on 17 Sep, 2017 11:42 PM

    Loren Stephens's Avatar

    I turned off suggest filenames. Now when I save with hide ext checked it saves the file as multimarkdown. If I save with hide ext un-checked it gives me untitled.txt. It seems like it should save the file as a txt file checked or un-checked?

    > On Sep 17, 2017, at 4:17 PM, Fletcher <[email blocked]> wrote:
    >
    > // Please reply above this line
    > ==================================================
    >
    > From: Fletcher (Support staff)
    >
    > Turn off the "Suggest filenames..." preferences.
    >
    > Looks like something is happening and it is including a newline before
    > the file extension. Use the arrow keys to move right/down inside the
    > file name box and you'll see what I mean.
    >
    > Is that right?
    >
    > On 9/17/17 7:13 PM, Loren Stephens wrote:
    > > // Please reply above this line
    > > ==================================================
    > >
    > > *From*: Loren Stephens <[email blocked]>
    > >
    > >
    > >
    > >> On Sep 17, 2017, at 3:52 PM, Fletcher
    > >> <[email blocked]
    > >> <***@***>> wrote:
    > >>
    >
    > On Sun, Sep 17 at 04:13 PM PDT, Loren Stephens wrote:
    >
    >
    >
    >
    >> On Sep 17, 2017, at 3:52 PM, Fletcher <[email blocked] <x-msg://3/***@***>> wrote:
    >>

  7. Support Staff 7 Posted by Fletcher on 17 Sep, 2017 11:45 PM

    Fletcher's Avatar

    Have you checked the "Get Info" window in the Finder for your file? The
    "Hide Extension" doesn't change the file extension, just whether it's
    visible. macOS hides most extensions by default.

    On 9/17/17 7:42 PM, Loren Stephens wrote:
    > // Please reply above this line
    > ==================================================
    >
    > *From*: Loren Stephens <[email blocked]>
    >
    > I turned off suggest filenames. Now when I save with hide ext checked it
    > saves the file as multimarkdown. If I save with hide ext un-checked it
    > gives me untitled.txt. It seems like it should save the file as a txt
    > file checked or un-checked?
    >
    > > On Sep 17, 2017, at 4:17 PM, Fletcher

  8. 8 Posted by Loren Stephens on 18 Sep, 2017 12:25 AM

    Loren Stephens's Avatar

    So I saved the file with hide extension checked. Here's the way it saved the file. Am I missing something?

  9. Support Staff 9 Posted by Fletcher on 18 Sep, 2017 12:30 AM

    Fletcher's Avatar

    Not sure what's going on -- just leave the hide extension unchecked so
    you can verify the proper extension.

    I'll keep looking at it.

    F-

  10. 10 Posted by Loren Stephens on 18 Sep, 2017 12:33 AM

    Loren Stephens's Avatar

    Sounds good. Have a good evening.

    Loren

  11. Support Staff 11 Posted by Fletcher on 18 Sep, 2017 07:23 PM

    Fletcher's Avatar

    Dug into this and figured it out. The OS was overriding the specified extension with the default for the file UTI, unless the extension was visible, in which case it worked.

    I rewrote the relevant code, and now it works whether the extension is visible or not.

    Available in 4.0.2 (I needed to get 4.0.1 submitted for more urgent issues). So it will still be a few days.

    But in the meantime, leave the "hide extension" button unchecked, and all should be fine.

    Thanks!!

    Fletcher

  12. Fletcher closed this discussion on 18 Sep, 2017 07:23 PM.

  13. Loren Stephens re-opened this discussion on 18 Sep, 2017 08:04 PM

  14. 12 Posted by Loren Stephens on 18 Sep, 2017 08:04 PM

    Loren Stephens's Avatar

    Thank you for taking the time to look into this.

    Loren

  15. Fletcher closed this discussion on 18 Sep, 2017 08:33 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac