Bold and Italic formatting

Stefan's Avatar


21 Aug, 2017 09:28 AM

Formattino Italic or Bold via Shortcut or Menu fails with replacing the selected text with the text "TypeError".

  1. Support Staff 1 Posted by Fletcher on 21 Aug, 2017 12:11 PM

    Fletcher's Avatar

    Can you give a specific example? It works for me.

  2. Support Staff 2 Posted by Fletcher on 21 Aug, 2017 12:36 PM

    Fletcher's Avatar

    (Rephrase -- adding bold works for me. I still need to implement removing bold)

  3. 3 Posted by Stefan on 21 Aug, 2017 02:39 PM

    Stefan's Avatar

    I added two screenshots, one before hitting cmd+i and one after. I can't figure out where the inserted text is coming from. In the clipboard is something else.

    I tried a new file and it worked perfect. The file I had trouble with is rather big with lots of chapters, tables and links in it.

  4. Support Staff 4 Posted by Fletcher on 21 Aug, 2017 03:03 PM

    Fletcher's Avatar

    Ahhh... German. There is a bug in the bold/italics code where I accounted for multibyte characters twice (e.g. ü is actually two bytes, but one character)... Fixed for next release.


  5. Fletcher closed this discussion on 21 Aug, 2017 03:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac